Upstream Routing Failure

Resolved in 2 hours

Incident timeline

Operational
Resolved
Issues with the upstream provider have been resolved.
2022-12-07 09:39:00 UTC - 2 months
Outage
Investigating
Outage detected
2022-12-07 07:26:00 UTC - 2 months