MX Processing Issues

Resolved in 11 hours

Incident timeline

Degraded performance
Resolved
MX has reported that they have solved the issue, confirmed by our automation.
2023-11-30 18:10:34 UTC - 3 months
Degraded performance
Investigating
MX Sandbox environment is experiencing degraded performance.
2023-11-30 07:12:00 UTC - 3 months